HDU 1072 Nightmare( 身上带有定时炸弹的他能否在炸弹爆炸之前离开—— BFS+DP思想)



Nightmare
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes. 

Given the layout of the labyrinth and Ignatius‘ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1. 

Here are some rules: 
1. We can assume the labyrinth is a 2 array. 
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too. 
3. If Ignatius get to the exit when the exploding time turns to 0, he can‘t get out of the labyrinth. 
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can‘t use the equipment to reset the bomb. 
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish. 
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6. 
 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth. 
There are five integers which indicate the different type of area in the labyrinth: 
0: The area is a wall, Ignatius should not walk on it. 
1: The area contains nothing, Ignatius can walk on it. 
2: Ignatius‘ start position, Ignatius starts his escape from this position. 
3: The exit of the labyrinth, Ignatius‘ target position. 
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas. 
 

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1. 
 

Sample Input

3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output

4 -1 13
 

题目大意:

一个人在迷宫里并且身上带有定时炸弹,炸弹经过6秒就会爆炸,在这个迷宫里面有5种属性的方格,2代表出发点,3代表出口,1代表可以走的路,0代表墙,4代表在此点可以把当前的定时炸弹重置为6 . PS:在出口可以出去的条件是定时炸弹剩余时间大于0,同样重置炸弹时间的条件是当前炸弹的爆炸时间大于0.

解题思路:

BFS+DP,当遇到下一步可以带的时间比实际那一步多则更新爆炸时间。.

代码:

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>

using namespace std;

int dirI[4]={1,0,-1,0},is,js,ie,je,n,m;
int dirJ[4]={0,1,0,-1},timen[10][10];

struct node{
    int i,j,t,v;
    node(int i0=0,int j0=0,int t0=0,int v0=0){
        i=i0,j=j0,t=t0,v=v0;
    }
}a[10][10];

void bfs(){
    queue <node> path;
    timen[is][js]=0;
    a[is][js].t=6;
    bool ans=false;
    path.push(a[is][js]);
    while(!path.empty()&&!ans){
        node s=path.front();
        path.pop();
        for(int i=0;i<4;i++){
            int di=s.i+dirI[i],dj=s.j+dirJ[i];
            if(a[di][dj].v==0||di<0||dj<0||di>=n||dj>=m) continue;
            int temp=timen[s.i][s.j]+1,st=s.t-1 ;
            if(st>a[di][dj].t||timen[di][dj]==-1){
                if(a[di][dj].v==4&&st>=1) {st=6;a[di][dj].t=st;timen[di][dj]=temp;path.push(a[di][dj]);}
                if(a[di][dj].v==1) {a[di][dj].t=st;timen[di][dj]=temp;path.push(a[di][dj]);}
                if(a[di][dj].v==3&&st>=1){ans=true;timen[di][dj]=temp;break;}
            }
        }
    }
    printf("%d\n",timen[ie][je]);
}

int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        memset(timen,-1,sizeof(timen));
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                scanf("%d",&a[i][j].v);
                a[i][j].i=i,a[i][j].j=j,a[i][j].t=0;
                if(a[i][j].v==2) {is=i,js=j;}
                if(a[i][j].v==3) {ie=i,je=j;}
            }
        }
        bfs();
    }
    return 0;
}




郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。