POJ 1861 & ZOJ 1542 Network(最小生成树之Krusal)

题目链接:

PKU:http://poj.org/problem?id=1861

ZJU:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=542


Description

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs). 
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections. 
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied. 

Input

The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 106. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.

Output

Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1
4
1 2
1 3
2 3
3 4

Source

Northeastern Europe 2001, Northern Subregion

PS:

貌似题目的案例有点问题,卡了好久!

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int inf = 9999999;
const int maxn = 15017;
int father[maxn];
struct edge
{
    int x,y,v;
};
struct edge ed[maxn],ansa[maxn];

bool cmp(edge a,edge b)
{
    return a.v<b.v;
}

int find(int x)
{
    if(x==father[x])
        return x;
    return father[x]=find(father[x]);
}

void Krusal(int n,int m)
{
    int i,fx,fy,cnt;
    int ans=0;
    for(i = 1; i <= n; i++)
        father[i]=i;
    sort(ed,ed+m,cmp);//对边的排序
    cnt=0;
    int max=-1;
    for(i=0; i<m; i++)
    {
        fx=find(ed[i].x);
        fy=find(ed[i].y);
        if(fx!=fy)
        {
            ans+=ed[i].v;
            father[fx]=fy;
            ansa[cnt].x=ed[i].x;
            ansa[cnt++].y=ed[i].y;
            if(max<ed[i].v)
                max=ed[i].v;
        }
    }
    printf("%d\n%d\n",max,cnt);
    for(i=0; i<cnt; i++)
        printf("%d %d\n",ansa[i].x,ansa[i].y);
}

int main()
{
    int t;
    int n, m;
    int a, b, k;

    while(scanf("%d %d",&n,&m)!=EOF)
    {
        for(int i = 0; i < m; i++)
        {
            scanf("%d %d %d",&a,&b,&k);
            ed[i].x=a,ed[i].y=b,ed[i].v=k;
        }
        Krusal(n,m);
    }
    return 0;
}


郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。