poj 2531 Network Saboteur (dfs)

Network Saboteur
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 9364   Accepted: 4417

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). 
Output file must contain a single integer -- the maximum traffic between the subnetworks. 

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

百度了一下才知道思路,继续努力。。。

题意:把一个连通的集合分成两个不连通的集合,求这两个集合间最大的信息交换量。

每个点(电脑)可以由两个选择,分给A集合或者B集合。

每次把一个点分类后,立即求出它和另一个集合的交换信息量。


#include<stdio.h>
#include<queue>
#include<map>
#include<string>
#include<string.h>
using namespace std;
#define N 25
const int inf=0x1f1f1f1f;
int g[N][N];
int ans,n;
bool f[N];
void dfs(int u,int sum)
{
    if(u>=n)
    {
        ans=max(ans,sum);
        return ;
    }
    int i,tmp=0;
    f[u]=false;         //把点U分为集合A
    for(i=0;i<u;i++)   //求点U和集合B交换的信息量
        if(f[i]==true)
            tmp+=g[u][i];
    dfs(u+1,sum+tmp);
    f[u]=true;          //把点U分为集合B
    for(i=tmp=0;i<u;i++) //求点U和集合A交换的信息量
        if(f[i]==false)
        tmp+=g[u][i];
    dfs(u+1,sum+tmp);
}
int main()
{
    int i,j;
    while(scanf("%d",&n)!=-1)
    {
        for(i=0; i<n; i++)
            for(j=0; j<n; j++)
                scanf("%d",&g[i][j]);
        ans=0;
        dfs(0,0);
        printf("%d\n",ans);
    }
    return 0;
}


郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。