BZOJ 1029: [JSOI2007]建筑抢修 优先队列
1029: [JSOI2007]建筑抢修
Time Limit: 4 Sec Memory Limit: 162 MB题目连接
http://www.lydsy.com/JudgeOnline/problem.php?id=1029
Description
Input
Output
Sample Input
100 200
200 1300
1000 1250
2000 3200
Sample Output
HINT
题解:
首先按照结束时间进行排序
用一个大根堆,把每次可行的事情都扔进去,如果遇到一件事儿不行的时候,那么我们就把这件事情所花费的时间与大根堆的第一个进行对比
如果比他消耗时间小的话,那么必然可以替代那件事儿
证明还是挺简单的,想想就清楚了
代码:
//qscqesze
#include <cstdio>
#include <cmath>
#include <cstring>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <set>
#include <vector>
#include <sstream>
#include <queue>
#include <typeinfo>
#include <fstream>
#include <map>
typedef long long ll;
using namespace std;
//freopen("D.in","r",stdin);
//freopen("D.out","w",stdout);
#define sspeed ios_base::sync_with_stdio(0);cin.tie(0)
#define maxn 200001
#define mod 10007
#define eps 1e-9
//const int inf=0x7fffffff; //无限大
const int inf=0x3f3f3f3f;
/*
*/
//**************************************************************************************
inline ll read()
{
int x=0,f=1;char ch=getchar();
while(ch<‘0‘||ch>‘9‘){if(ch==‘-‘)f=-1;ch=getchar();}
while(ch>=‘0‘&&ch<=‘9‘){x=x*10+ch-‘0‘;ch=getchar();}
return x*f;
}
struct node
{
int x,y;
};
bool cmp(node a,node b)
{
return a.y<b.y;
}
node a[maxn];
priority_queue<int> q;
int main()
{
int n;
cin>>n;
for(int i=0;i<n;i++)
a[i].x=read(),a[i].y=read();
sort(a,a+n,cmp);
int now=0;
int ans=0;
for(int i=0;i<n;i++)
{
if(now+a[i].x<=a[i].y)
{
ans++;
now+=a[i].x;
q.push(a[i].x);
}
else
{
int h=q.top();
if(a[i].x<h)
{
q.pop();
q.push(a[i].x);
now=now+a[i].x-h;
}
}
}
cout<<ans<<endl;
}
郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。