Android SwipeRefreshLayout 官方下拉刷新控件介绍

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8
 
一个送外卖的人,要将外卖全部送去所有地点再回到店离,求最短路
首先用floyd求出最短路,然后再进行DP即可
 
dp[i][j]表示i这个状态下,目标是j的最短路,i是用二进制表示每个地点是否去过
 
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int map[20][20],dis[20][20],dp[1<<11][20];

int main()
{
    int n,i,j,k;
    while(~scanf("%d",&n),n)
    {
        for(i = 0; i<=n; i++)
            for(j = 0; j<=n; j++)
            {
                scanf("%d",&map[i][j]);
                dis[i][j] = map[i][j];
            }
        for(j = 0; j<=n; j++)
            for(i = 0; i<=n; i++)
                for(k = 0; k<=n; k++)
                    if(dis[i][j]>dis[i][k]+map[k][j])
                        dis[i][j] = dis[i][k]+map[k][j];
        memset(dp,-1,sizeof(dp));
        dp[1][0] = 0;
        for(i = 1; i<1<<(n+1); i++)
        {
            i = i|1;
            for(j = 0; j<=n; j++)
            {
                if(dp[i][j]!=-1)
                {
                    for(k = 0; k<=n; k++)
                    {
                        if(j!=k && (dp[(1<<k)|i][k]==-1 || dp[(1<<k)|i][k]>dp[i][j]+dis[j][k]))
                            dp[(1<<k)|i][k]=dp[i][j]+dis[j][k];
                    }
                }
            }
        }
        printf("%d\n",dp[(1<<(n+1))-1][0]);
    }

    return 0;
}

Android SwipeRefreshLayout 官方下拉刷新控件介绍,,5-wow.com

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。