POJ2385 Apple Catching 【DP】

Apple Catching
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8018   Accepted: 3922

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

Hint

INPUT DETAILS: 

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice. 

OUTPUT DETAILS: 

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

Source

题意:有一头牛,两棵树,开始牛在1号树下,每秒钟两棵树中的某一棵会掉下一颗苹果,牛最多能在这两棵树间移动W次,求N秒钟内牛最多能接到多少颗苹果。

题解:最近做的好些题都是关于这头牛的,又是擦地板,又是走迷宫,又是晒太阳...这会又跑来接苹果,简直碉堡了..咳咳,言归正传,这题的状态是dp[i][j]表示第i秒移动最多j步接到的最多苹果。状态转移方程为dp[i][j] = max(dp[i-1][j], dp[i][j-1]);

#include <stdio.h>
#include <string.h>

int dp[1010][35];
bool arr[1010];

int max(int a, int b) {
    return a > b ? a : b;
}

int main() {
    int T, W, i, j, tmp, ans = 0;
    scanf("%d%d", &T, &W);
    for(i = 1; i <= T; ++i) {
        scanf("%d", &tmp);
        arr[i] = tmp - 1;
    }
    if(arr[1]) dp[1][1] =1;
    else dp[1][0] = 1;
    ans = 1;
    for(i = 2; i <= T; ++i) {
        dp[i][0] = dp[i-1][0] + !arr[i];
        for(j = 1; j <= W; ++j) {
            dp[i][j] = max(dp[i-1][j], dp[i][j-1]);
            dp[i][j] += !((j & 1) ^ arr[i]);
            if(dp[i][j] > ans) ans = dp[i][j];
        }
    }
    printf("%d\n", ans);
    return 0;
}



郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。