杭电1047(Integer Inquiry)java水过

Problem Description

One of the first users of BIT‘s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,‘‘ remarked Chip. ``I only wish Timothy were here to see these results.‘‘ (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)
 


 

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.
 


 

Output

Your program should output the sum of the VeryLongIntegers given in the input.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 


 

Sample Input

3
123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
 
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0
 
0
 


 

Sample Output

370370367037037036703703703670
 
370370367037037036703703703670
 
0

 

注:格式问题!!

代码实现

import java.math.BigInteger;
import java.util.Scanner;
class Main{
    public static void main(String[] args){
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        while(n-->0){
	   BigInteger sum=BigInteger.ZERO;
            BigInteger x;
	        while(sc.hasNextBigInteger()){
            	x=sc.nextBigInteger();
            	if(x.equals(BigInteger.valueOf(0))){
            		System.out.println(sum);
            		break;
            	}else{
            		sum=sum.add(x);
            	}
            }
            if(n!=0){
            	System.out.println();
            }
        }
    }
}


 

 

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。