杭电2024(C语言合法标识符)


Problem Description
输入一个字符串,判断其是否是C的合法标识符。
 

Input
输入数据包含多个测试实例,数据的第一行是一个整数n,表示测试实例的个数,然后是n行输入数据,每行是一个长度不超过50的字符串。
 

Output
对于每组输入数据,输出一行。如果输入数据是C的合法标识符,则输出"yes",否则,输出“no”。
 

Sample Input
3 12ajf fi8x_a ff ai_2
 
Sample Output
no yes

no


思路:代码实现其实很简单,只是问题卡在输完数字后面那个换行符的处理上面。

import java.util.*;
class Main{
	public static void main(String args[]){
		Scanner sc=new Scanner(System.in);
		int n=sc.nextInt();
		sc.nextLine();
		while(n-->0 ){
			String str=sc.nextLine();
			if((str.charAt(0)>='a'&&str.charAt(0)<='z')||(str.charAt(0)>='A'&&str.charAt(0)<='Z')||(str.charAt(0)=='_')){
				int k=0;
				for(int i=1;i<str.length();i++){       
					if((str.charAt(i)>='a'&&str.charAt(i)<='z')||(str.charAt(i)>='A'&&str.charAt(i)<='Z')||(str.charAt(i)>='0'&&str.charAt(i)<='9')||(str.charAt(i)=='_'))
						k++;
				}
				if(k==(str.length()-1)){
					System.out.println("yes");   
				}else{
					System.out.println("no");
				}
			}else{
				System.out.println("no");
	 		}
		}
	}
}

注意:为了不然输入数字后面的换行被装进字符串,有这种错误的做法:
Scanner sc1=new Scanner(System.in);
Scanner sc2=new Scanner(System.in);
while(sc1.hasNext()){
	int n=sc1.nextInt();
	while(n-->0 ){
		String str=sc2.nextLine();
                ........

看似换行符被吸收了,实际上没有,键盘输入时,换行符已经存在数据流中了,这种方法只是让两个字符串来装,而装到那个字符串中是不一定的,所以不能ac!!!



郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。