POJ 2305 Basic remains(JAVA练习)

Description

Given a base b and two non-negative base b integers p and m, compute p mod m and print the result as a base b integer. p mod m is defined as the smallest non-negative integer k such that p = a*m + k for some integer a.

Input

Input consists of a number of cases. Each case is represented by a line containing three unsigned integers. The first, b, is a decimal number between 2 and 10. The second, p, contains up to 1000 digits between 0 and b-1. The third, m, contains up to 9 digits between 0 and b-1. The last case is followed by a line containing 0.

Output

For each test case, print a line giving p mod m as a base-b integer.

Sample Input

2 1100 101
10 123456789123456789123456789 1000
0

Sample Output

10
789
求p%m的b进制表示。果断java。
import java.io.*;
import java.math.*;
import java.util.*;

public class Main {
	public static void main(String[] arges){
        Scanner cin = new Scanner (System.in);
		int b;
		BigInteger p,m,ans;
		while(cin.hasNext())
		{
			b=cin.nextInt();
			String str;
			if(b==0)  break;
			p=cin.nextBigInteger(b);
			m=cin.nextBigInteger(b);
			ans=p.mod(m);
			str=ans.toString(b);
			System.out.println(str);
		}
	}
}


郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。