克鲁斯卡尔算法 有大坑 hdu 1102

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15475    Accepted Submission(s): 5907


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 

Sample Input
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
179
 

Source
 

//考查知识点:克鲁斯卡尔算法 最小生成树 
//大坑 :下面的n行 n列的数的理解,应该理解为n阶方阵 大坑二:此处的数目 不能用count 用count 通过deve 编译通不过
#include<stdio.h>
#include<algorithm>
using namespace std;
int father[100100];
struct node{
	int sta,end,wei;
}s[100100];

//int count;

int p;

int cmp(node x,node y)
{
	return x.wei<y.wei;
}
int find(int x)
{
	return x==father[x]?x:find(father[x]);
}
void kruskal()
{
	int i,sum=0;
	for(i=0;i<p;++i)
	{
		int x=s[i].sta,y=s[i].end,z=s[i].wei;
		int fa=find(x);
		int fb=find(y);
		if(fa!=fb)
		{
			sum+=z;
			father[fa]=fb;
		}
	}
	printf("%d\n",sum);
}
int main()
{
	int i,j;
	int n,m;
	while(~scanf("%d",&n))
	{
		p=0;
		for(i=0;i<10010;++i)
		father[i]=i;
		for(i=1;i<=n;++i)
		{
			for(j=1;j<=n;++j)
			{
				scanf("%d",&s[p].wei);
				s[p].sta=i;
				s[p].end=j;
				p++;
			}
		}
		
		scanf("%d",&m);
		while(m--)
		{
			scanf("%d%d",&i,&j);
			int fa=find(i);
			int fb=find(j);
			if(fa!=fb)
			father[fa]=fb;
		}	
		sort(s,s+p,cmp);
		kruskal();
	}
	return 0;
} 


郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。