hdu 1072 Nightmare

Nightmare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6980    Accepted Submission(s): 3348


Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius‘ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can‘t get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can‘t use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius‘ start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius‘ target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 

Sample Input
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output
4 -1 13
 
题意:
Ignatius 梦到自己在一个城堡有个定时炸弹城堡内,炸弹在6秒后爆炸,若走到4则能将炸弹调回6秒后爆炸。调制炸弹和到达门口时都要时间大于0,若能走到出口3,则输出所用最小时间,否则输出-1。

总结:
我觉得此题不难,但是我还是题意理解错误,原以为要标记路径。看了别人博客后才知道只要标记重置点就OK。

BFS:
<span style="font-size:24px;">#include<stdio.h>
#include<queue>
using namespace std;
int n,m;
int dir[4][2]={{0,-1},{-1,0},{0,1},{1,0}};
int map[9][9];
int startx,starty;

struct node
{
    int i,j;
	int time,step;
};

int bfs(int a,int b)
{   
	int i;
    queue<node>q;
    node start,cur,next;
	
	start.i=a;
	start.j=b;
    start.time=6;
    start.step=0;

    q.push(start);
    while(!q.empty())
    {
       cur=q.front();
       q.pop();

	   if(map[cur.i][cur.j]==3)   // 找到终点
             return cur.step;   

       for(i=0;i<4;i++)
       {
           next.i=cur.i+dir[i][0];
           next.j=cur.j+dir[i][1];
           next.time=cur.time-1;
           next.step=cur.step+1;
           if(next.i>=0&&next.i<n &&next.j>=0&&next.j<m &&map[next.i][next.j]!=0 &&next.time>0)  // 时间要大于0
           {
              if(map[next.i][next.j]==4)
              {
                  next.time=6;
                  map[next.i][next.j]=0;   // '4'(重置点)只走一次最优,'1'可以走多次.
              }
              q.push(next);
           }
       }
    }
    return -1;
}

 
int main()
{
    int i,j,k;
    scanf("%d",&k);
    while(k--)
    {
       scanf("%d %d",&n,&m);
       for(i=0;i<n;i++)
           for(j=0;j<m;j++)
           {
              scanf("%d",&map[i][j]);
              if(map[i][j]==2)
              {
                  startx=i;
                  starty=j;
              }
           }
     printf("%d\n",bfs(startx,starty));
    }
    return 0;
}</span>


hdu 1072 Nightmare,古老的榕树,5-wow.com

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。