Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35848    Accepted Submission(s): 13581


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

 

Output
For each test case, you should output the rightmost digit of N^N.
 

 

Sample Input
2 3 4
 

 

Sample Output
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 
 
思路:一道简单的快速幂,刚开始看错了题目,一直没有思路。
若把a^b%c看做b个a相乘并分布求余,b太大显然会超时,快速幂的原理是:降低 b 的次数,把a变大(涉及求余,对a不影响);
技术分享
#include<cstdio>
int powermod(int a,int b,int c)
{
    int ans=1;
    a=a%c;
    if(a==0)
    return 0;
    while(b>0)
    {
        if(b%2==1)
        ans=ans*a%c;
        b/=2;
        a=a*a%c;
    }
    return ans;
}
int main()
{
    int T;
    int n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        printf("%d\n",powermod(n,n,10));
    }
    return 0;
}
View Code

 

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。