CPP 1373 Easy as A+B(冒泡排序)

题目链接: http://cpp.zjut.edu.cn/ShowProblem.aspx?ShowID=1373


题面:

Easy as A+B 
Time Limit:1000MS  Memory Limit:32768K

Description:

These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights. Give you some integers, your task is to sort these number ascending. You should know how easy the problem is now! Good luck!

Input:

Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line. It is guarantied that all integers are in the range of 32bit-int.

Output:

For each case, print the sorting result, and one line one case.

Sample Input:

2
3 2 1 3
9 1 4 7 2 5 8 3 6 9

Sample Output:

1 2 3
1 2 3 4 5 6 7 8 9

Source:

lcy

题解:

    冒泡排序一下,套了下别人写的,居然是错的,以后还是自己写吧。


代码:

#include <stdio.h>
int main() 
{ 
  int temp,t,n; 
  int store[1005]; 
  scanf("%d",&t);
  while(t--)
  {
    scanf("%d",&n);
    for(int i=0;i<n;i++) 
    scanf ("%d,",&store[i]); 
    for (int i = 0; i < n; i++)
            {
                for (int j = i; j < n; j++)
                {
                    if (store[i] > store[j])
                    {
                        temp = store[i];
                        store[i] = store[j];
                        store[j] = temp;
                    }
                }
            }
    printf("%d",store[0]);
    for(int i=1;i<n;i++) 
      printf(" %d",store[i] ); 
    printf("\n");
  }
  return 0;
}



郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。