poj 2182 Lost Cows 树状数组

Lost Cows
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9477   Accepted: 6110

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood ‘watering hole‘ and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands. 

Regrettably, FJ does not have a way to sort them. Furthermore, he‘s not very good at observing problems. Instead of writing down each cow‘s brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow. 

Given this data, tell FJ the exact ordering of the cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on. 

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1

给出n和每个数之前比它小的数有几个 需要输出原序列

最后一个数的真实值为a[N]+1

将a[N]+1在序列中删去,更新a[i],那么第N-1个数的真实值为a[N-1]+1

二分找需要删的值

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int bit[8888],ans[8888];
int a[8888],n;
int lowbit(int x){
    return x&(-x);
}
int getsum(int x){
    int cnt=0;
    while(x>0){
	cnt+=bit[x];
	x-=lowbit(x);
    }
    return cnt;
}
void add(int x,int a){
    while(x<8888){
	bit[x]+=a;
	x+=lowbit(x);
    }
}
int bin_find(int x){
    int l=1,r=n,m;
    while(l<=r){
	m=(l+r)>>1;
	int k=getsum(m);
	if(k>=x)
	    r=m-1;
	else l=m+1;
    }
    while(getsum(m)<x)
	m++;
    return m;
}
int main(){
    while(scanf("%d",&n)!=EOF){
	a[1]=0;
	for(int i=2;i<=n;i++)
	    scanf("%d",&a[i]);
	memset(bit,0,sizeof(bit));
	for(int i=1;i<=n;i++)
	    add(i,1);
	for(int i=n;i>=1;i--){
	    ans[i]=bin_find(a[i]+1);
	    add(ans[i],-1);
	}
	for(int i=1;i<=n;i++)
        printf("%d\n",ans[i]);
    }
    return 0;
}


郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。