hdu 3342 Legal or Not 拓扑排序判断环。 现在的我,除了刷水题,,还能干什么

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4960    Accepted Submission(s): 2270


Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it‘s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian‘s master and, at the same time, 3xian is HH‘s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B‘s master ans B is C‘s master, then A is C‘s master.
 

Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y‘s master and y is x‘s prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 

Sample Input
3 2 0 1 1 2 2 2 0 1 1 0 0 0
 

Sample Output
YES NO
 没什么可讲的。就会拓扑模板题
直接代码:
#include <stdio.h>
#include <string.h>
#define MAX 110
int graph[MAX][MAX] , in[MAX];
bool visited[MAX] ;
int main()
{
	int m,n;
	while(~scanf("%d%d",&n,&m) && n)
	{
		memset(graph,0,sizeof(graph)) ;
		memset(visited,false,sizeof(visited)) ;
		memset(in,0,sizeof(in)) ;
		for(int i = 0 ; i < m ; ++i)
		{
			int x , y ;
			scanf("%d%d",&x,&y) ;
			if(graph[x][y] == 0)
			{
				graph[x][y] = 1 ;
				in[y] ++ ;
			}
		}
		int count = 0 ;
		for(int i = 0 ;i < n ; ++i)
		{
			for(int j = 0 ; j < n ; ++j)
			{
				if(!visited[j] && in[j] == 0)
				{
					count ++ ;
					visited[j] = true ; 
					for(int k = 0 ; k < n ; ++k)
					{
						if(graph[j][k] == 1)
						{
							graph[j][k] = 0 ;
							in[k]-- ;
						}
					}
					break ; 
				}
			}
		}
		if(count < n)
		{
			puts("NO") ;
		}
		else
		{
			puts("YES") ;
		}
	}
	
	return 0 ;
}

与君共勉

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。