hdu 1541 Stars 树状数组水题

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5210    Accepted Submission(s): 2053


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

技术分享

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it‘s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
1 2 1 1 0
 
按照y的增序给出星星的坐标 如果有n颗星星在一颗星星的左下角 那这颗星星的等级就是n+1,问每个等级有几颗星星
树状数组题目 每次给出坐标时求一次getsum(x)
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int bit[32222],ans[15555];
int n;
int lowbit(int x){
    return x&(-x);
}
int getsum(int x){
    int cnt=0;
    while(x>0){
	cnt+=bit[x];
	x-=lowbit(x);
    }
    return cnt;
}
void add(int x,int a){
   while(x<32222){
      bit[x]+=a;
     x+=lowbit(x);
   }
}
int main(){
    int x,y;
    while(scanf("%d",&n)!=EOF){
	memset(ans,0,sizeof(ans));
	memset(bit,0,sizeof(bit));
	for(int i=1;i<=n;i++){
	    scanf("%d %d",&x,&y);
	    x++;
	    ans[getsum(x)]++;
	    add(x,1);
	}
	for(int i=0;i<n;i++)
	    printf("%d\n",ans[i]);
    }
    return 0;
}


郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。