编辑文章 - 博客频道 - CSDN.NET

Problem Description
Let‘s consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.
For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is
the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).

Input
You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.

Output
If a winning strategies can be found, print a single line with "Yes", otherwise print "No".

Sample Input
2 2 2 1 3

Sample Output
No Yes
#include<stdio.h>
int main()
{
int n,a,c,t;
while(scanf("%d",&n)==1)
{
  c=0;t=0;
for(int i=0;i<n;i++)
{
scanf("%d",&a); c^=a; if(a>1) t=1;
}
printf("%s\n",(c!=0&&t||c==0&&t==0)?"Yes":"No");
}
}



郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。