Axis2 webservice 各种jar包使用(缺包的异常)

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12235    Accepted Submission(s): 4655


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
 

Sample Input
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
179
 


#include"stdio.h"
#include"string.h"
#include"math.h"
#define N 105
const int Inf=10000;
int main()
{
	int n,q,i,j,a,b,ans,s,index,min;
	int map[N][N],mark[N],dis[N];
	while(scanf("%d",&n)!=-1)
	{
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				scanf("%d",&map[i][j]);
		scanf("%d",&q);
		while(q--)       //已经连通的的点距离改记为0;
		{
			scanf("%d%d",&a,&b);
			map[a][b]=0;
			map[b][a]=0;
		}
		s=1;      //先加入一个点,然后更新其余点与该点的距离
		ans=0;
		memset(mark,0,sizeof(mark));
		mark[1]=1;      
		for(i=1;i<=n;i++)
			dis[i]=map[s][i];        
		while(1)
		{
			index=1;
			min=Inf;
			for(i=1;i<=n;i++) 
				if(!mark[i]&&dis[i]<min)       //找到距离该点最近的点,加入集合
				{
					index=i;
					min=dis[i];
				}
			if(index==1)          //完成建路任务
				break;
			mark[index]=1;        
			ans+=min;          
			for(i=1;i<=n;i++)           //若存在集合外的点距离新加入点的距离小于以前距离,更新
				if(!mark[i]&&map[index][i]<dis[i])
					dis[i]=map[index][i];
		}
		printf("%d\n",ans);
	}
	return 0;
}


Axis2 webservice 各种jar包使用(缺包的异常),古老的榕树,5-wow.com

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。