poj 2006 Happy2006

Happy 2006
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 9936   Accepted: 3411

Description

Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006. 

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order. 

Input

The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output

Output the K-th element in a single line.

Sample Input

2006 1
2006 2
2006 3

Sample Output

1
3
5
题目翻译:给出m,k,求第k个和m互质的数字!
解题思路:数据量较大,因此全部采用long long,想求出第k个互质的数,数据量太大,因此采用2分查找,来找d第K个数字,想知道当前数字t是第几个与m的互质的数,需要求出t前有几个与m不互质的数字,利用容斥原理,可以解决,然后对比即可!
#include<cstdio>
#define LL long long
LL p[20],top;
void getp(LL m){
    LL i;
    for(i=2,top=0;i*i<=m;i++)
        if(m%i==0){
            p[top++]=i;
            while(m%i==0) m/=i;
        }
    if(m>1) p[top++]=m;
}
LL nop(LL mid,LL t){
    LL i,sum=0;
    for(i=t;i<top;i++)
        sum+=mid/p[i]-nop(mid/p[i],i+1);
    return sum;
}
int main(){
    LL k,m;
    while(scanf("%lld%lld",&m,&k)==2){
        LL mid,l=0,r=0x3f3f3f3f3f3f3f3f,t,ans=0;
        getp(m);
        while(l<=r){
            mid=(l+r)>>1;
            t=mid-nop(mid,0);
            if(t>=k){
                r=mid-1;
                if(t==k) ans=mid;
            }
            else l=mid+1;
        }
        printf("%lld\n",ans);
    }
    return 0;
}

郑重声明:本站内容如果来自互联网及其他传播媒体,其版权均属原媒体及文章作者所有。转载目的在于传递更多信息及用于网络分享,并不代表本站赞同其观点和对其真实性负责,也不构成任何其他建议。